AliRoot prerequisites for Fedora

Table of contents

Follow these instructions to prepare your Fedora system to run AliRoot.

Required packages

Install (always as root or by prepending sudo) all the required packages with a single command (please note that it is a long line):

yum install autoconf automake libtool cmake zlib-devel libxml2-devel openssl-devel gcc-c++ gcc-gfortran make libX11-devel libXpm-devel libXft-devel libXext-devel mesa-libGLU-devel CGAL-devel subversion git

Please note that you should have at least CMake v2.8.12. You can check with:

$> cmake --version
cmake version 2.8.12.2

If you do not have this version available with your Fedora version, you can always install one manually.

git-new-workdir

Check if you have the executable named git-new-workdir available in your $PATH:

which git-new-workdir

If nothing appears, you do not have it installed. Install it system-wide:

sudo curl -kL https://raw.github.com/gerrywastaken/git-new-workdir/master/git-new-workdir -o /usr/bin/git-new-workdir
sudo chmod 0777 /usr/bin/git-new-workdir